문제
N×M크기의 배열로 표현되는 미로가 있다.
1 | 0 | 1 | 1 | 1 | 1 |
1 | 0 | 1 | 0 | 1 | 0 |
1 | 0 | 1 | 0 | 1 | 1 |
1 | 1 | 1 | 0 | 1 | 1 |
미로에서 1은 이동할 수 있는 칸을 나타내고, 0은 이동할 수 없는 칸을 나타낸다. 이러한 미로가 주어졌을 때, (1, 1)에서 출발하여 (N, M)의 위치로 이동할 때 지나야 하는 최소의 칸 수를 구하는 프로그램을 작성하시오. 한 칸에서 다른 칸으로 이동할 때, 서로 인접한 칸으로만 이동할 수 있다.
위의 예에서는 15칸을 지나야 (N, M)의 위치로 이동할 수 있다. 칸을 셀 때에는 시작 위치와 도착 위치도 포함한다.
입력
첫째 줄에 두 정수 N, M(2 ≤ N, M ≤ 100)이 주어진다. 다음 N개의 줄에는 M개의 정수로 미로가 주어진다. 각각의 수들은 붙어서 입력으로 주어진다.
출력
첫째 줄에 지나야 하는 최소의 칸 수를 출력한다. 항상 도착위치로 이동할 수 있는 경우만 입력으로 주어진다.
예제 입력 1
4 6
101111
101010
101011
111011
예제 출력 1
15
예제 입력 2
4 6
110110
110110
111111
111101
예제 출력 2
9
예제 입력 3
2 25
1011101110111011101110111
1110111011101110111011101
예제 출력 3
38
예제 입력 4
7 7
1011111
1110001
1000001
1000001
1000001
1000001
1111111
예제 출력 4
13
#include <iostream>
#include <queue>
using namespace std;
char arr[101][101];
bool visit[101][101];
int minRoot[101][101];
int N, M;
int BFS(int x, int y)
{
int dx[4] = {0 ,0 ,1 ,-1 };
int dy[4] = {1 ,-1 ,0 ,0 };
queue<pair<int, int>> rootQueue;
rootQueue.push(make_pair(y,x));
visit[y][x] = true;
minRoot[y][x] = 1;
while (!rootQueue.empty())
{
int x = rootQueue.front().second;
int y = rootQueue.front().first;
rootQueue.pop();
for (int i = 0; i < 4; i++)
{
int tempX = x + dx[i];
int tempY = y + dy[i];
if (tempX > 0 && tempY > 0 && tempX <= M && tempY <= N &&
arr[tempY][tempX] == '1' && (!visit[tempY][tempX]))
{
minRoot[tempY][tempX] = minRoot[y][x] + 1;
visit[tempY][tempX] = true;
rootQueue.push(make_pair(tempY, tempX));
}
}
}
return 0;
}
int main()
{
ios_base::sync_with_stdio(false);
cin.tie(0);
cout.tie(0);
cin >> N >> M;
string input;
for (int i = 1; i <= N; i++)
{
cin >> input;
for (int j = 1; j <= M; j++)
{
arr[i][j] = input[j - 1];
}
}
BFS(1, 1);
cout << minRoot[N][M];
return 0;
}
728x90
반응형
'알고리즘 > solved.ac' 카테고리의 다른 글
[class3] (백준 6064) 카잉 달력 (0) | 2021.11.28 |
---|---|
[class3] (백준 2667) 단지번호붙이기 (0) | 2021.11.27 |
[class3] (백준 1992) 쿼드트리 (0) | 2021.11.25 |
[class3] (백준 1927) 최소 힙 (0) | 2021.11.24 |
[class3] (백준 1697) 숨바꼭질 (0) | 2021.11.23 |