문제
비어있는 공집합 S가 주어졌을 때, 아래 연산을 수행하는 프로그램을 작성하시오.
add x
: S에 x를 추가한다. (1 ≤ x ≤ 20) S에 x가 이미 있는 경우에는 연산을 무시한다.remove x
: S에서 x를 제거한다. (1 ≤ x ≤ 20) S에 x가 없는 경우에는 연산을 무시한다.check x
: S에 x가 있으면 1을, 없으면 0을 출력한다. (1 ≤ x ≤ 20)toggle x
: S에 x가 있으면 x를 제거하고, 없으면 x를 추가한다. (1 ≤ x ≤ 20)all
: S를 {1, 2, ..., 20} 으로 바꾼다.empty
: S를 공집합으로 바꾼다.
입력
첫째 줄에 수행해야 하는 연산의 수 M (1 ≤ M ≤ 3,000,000)이 주어진다.
둘째 줄부터 M개의 줄에 수행해야 하는 연산이 한 줄에 하나씩 주어진다.
출력
check
연산이 주어질때마다, 결과를 출력한다.
예제 입력 1
26
add 1
add 2
check 1
check 2
check 3
remove 2
check 1
check 2
toggle 3
check 1
check 2
check 3
check 4
all
check 10
check 20
toggle 10
remove 20
check 10
check 20
empty
check 1
toggle 1
check 1
toggle 1
check 1
예제 출력 1
1
1
0
1
0
1
0
1
0
1
1
0
0
0
1
0
#include <iostream>
#include <set>
using namespace std;
int main()
{
ios_base::sync_with_stdio(false);
cin.tie(0);
cout.tie(0);
set<int> S;
int M, num, temp;
string command;
cin >> M;
while (M-- > 0)
{
cin >> command;
if (command == "add")
{
cin >> num;
S.insert(num);
}
else if(command=="remove")
{
cin >> num;
S.erase(num);
}
else if (command == "check")
{
cin >> num;
temp = S.find(num)!=S.end();
cout << temp << '\n';
}
else if (command == "toggle")
{
cin >> num;
temp = S.find(num) != S.end();
if(temp)
S.erase(num);
else
S.insert(num);
}
else if (command == "all")
{
S = { 1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20 };
}
else if (command == "empty")
{
S.clear();
}
}
return 0;
}
728x90
반응형
'알고리즘 > solved.ac' 카테고리의 다른 글
[class3] (백준 1676) 팩토리얼 0의 개수 (0) | 2021.10.27 |
---|---|
[class3] (백준 1620) 나는야 포켓몬 마스터 이다솜 (0) | 2021.10.26 |
[class2] (백준 18111) 마인크래프트 (0) | 2021.10.24 |
[class2] (백준 2805) 나무 자르기 (0) | 2021.10.23 |
[class2] (백준 1654) 랜선 자르기 (0) | 2021.10.22 |