문제
세준이는 양수와 +, -, 그리고 괄호를 가지고 식을 만들었다. 그리고 나서 세준이는 괄호를 모두 지웠다.
그리고 나서 세준이는 괄호를 적절히 쳐서 이 식의 값을 최소로 만들려고 한다.
괄호를 적절히 쳐서 이 식의 값을 최소로 만드는 프로그램을 작성하시오.
입력
첫째 줄에 식이 주어진다. 식은 ‘0’~‘9’, ‘+’, 그리고 ‘-’만으로 이루어져 있고, 가장 처음과 마지막 문자는 숫자이다. 그리고 연속해서 두 개 이상의 연산자가 나타나지 않고, 5자리보다 많이 연속되는 숫자는 없다. 수는 0으로 시작할 수 있다. 입력으로 주어지는 식의 길이는 50보다 작거나 같다.
출력
첫째 줄에 정답을 출력한다.
예제 입력 1
55-50+40
예제 출력 1
-35
예제 입력 2
10+20+30+40
예제 출력 2
100
예제 입력 3
00009-00009
예제 출력 3
0
출처
- 문제를 번역한 사람: baekjoon
- 잘못된 조건을 찾은 사람: windflower
#include <iostream>
#include <string>
#include <deque>
#include <algorithm>
using namespace std;
deque<int> number;
deque<char> sign;
int min;
void parsing(string str)
{
int i;
string temp="";
for (i = 0; i < str.length(); i++)
{
if (str[i] == '+' || str[i] == '-')
{
sign.push_back(str[i]);
break;
}
temp += str[i];
}
number.push_back(stoi(temp));
if (i + 1 < str.length())
parsing(str.substr(i + 1));
}
int main()
{
ios_base::sync_with_stdio(false);
cin.tie(0);
cout.tie(0);
string input;
deque<int> final_number;
deque<char> final_sign;
cin >> input;
parsing(input);
int temp1, temp2;
int result;
if (sign.empty())
{
result = number.front();
}
else
{
while (!sign.empty())
{
if (sign.front() == '+')
{
temp1 = number.front();
number.pop_front();
temp2 = number.front();
number.pop_front();
number.push_front(temp1 + temp2);
sign.pop_front();
}
else if (sign.front() == '-')
{
final_number.push_back(number.front());
number.pop_front();
final_sign.push_back(sign.front());
sign.pop_front();
}
else
{
sign.pop_front();
}
if (number.size() < 2)
{
final_number.push_back(number.front());
number.pop_front();
break;
}
}
result = final_number.front();
final_number.pop_front();
while (!final_sign.empty())
{
result -= final_number.front();
final_number.pop_front();
final_sign.pop_front();
}
}
cout << result << '\n';
return 0;
}
728x90
반응형
'알고리즘 > solved.ac' 카테고리의 다른 글
[class3] (백준 1931) 회의실 배정 (0) | 2021.11.16 |
---|---|
[class3] (백준 1780) 종이의 개수 (0) | 2021.11.15 |
[class3] (백준 1012) 유기농 배추 (0) | 2021.11.13 |
[class3] (백준 1260) DFS와 BFS (0) | 2021.11.12 |
[class3] (백준 11727) 2 x n 타일링 2 (0) | 2021.11.11 |